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1 Introdu
tion

L'a

ou
hement est l'a
tion de mettre un enfant au monde. Il y a des étapes pour faire

l'a

ou
hement. Parmi elles, la phase de la dilatation, de l'expulsion et de délivran
e [1℄.

Pendant 
es étapes, il faut que les pro
édures soient bien appliquées par le personnel de la

santé, par
e que toutes les pro
édures impliquent des risques de la vie de la mère ou partu-

riente et de la vie du bébé.

Pour 
ette raison, divers simulateurs numériques ont été 
réés a�n de donner la possibilité de

ré
réer les étapes de l'a

ou
hement et de 
ette façon, servir 
omme un outil d'apprentissage

pour les étudiantes des domaines de la santé [2℄.

Le premier logi
iel a été développé par l'Université de Stanford [3℄, 
e logi
iel a été le premier

à mettre en appli
ation la réanimation néonatale. Après, di�érents logi
iels ont été 
onstruits

a�n de représenter les signes vitaux [4℄, et les premiers simulateurs physiques ont été déve-

loppé par SIMA, en 
her
hant représenter de manière 
omplète la réanimation néonatale

[5℄. L'entreprise Laerdal, après le développement des simulateurs d'adultes [6, 7℄ , a dé
idé

de travailler sur la 
on
eption d'un simulateur de nouveau-né, 
apable de simuler les signes

vitaux et d'autres 
onditions 
liniques des nouveaux-nés[8℄.

En 2012, le projet SAGA (Simulateurs pour l'Apprentissage des Gestes de l'A

ou
hement)

a été 
réé. Ce projet est dédié au développement des outils pédagogiques, a�n de simuler une

ambian
e 
omplète de l'a

ou
hement d'un nouveau-né. Cet projet a été divisé dans trois

parties : Modèle numérique, Système Physique et une Interfa
e graphique. Cha
une partie

aborde le projet en utilisant di�érents outils. Dans la �gure 1, vous pouvez voir l'ar
hite
ture

du projet SAGA.

L'idée prin
ipale est d'utiliser 
e système depuis une 
omposante pédagogique, en permettant

de designer des s
enarios 
liniques selon le publi
, les besoins et la di�
ulté souhaitée. [9℄.

Dans le s
héma de la �gure 1, on peut observer une relation entre 
haque module, 
'est

pourquoi le système donne la possibilité de prendre en 
ompte les a
tions implémentées

dans d'autres parties en fa
ilitant l'apprentissage et la véri�
ation de 
haque pro
édure

développée.

Dans 
e do
ument, on montrera, en premier lieu, le traitement de maillages de la tête foetale,

en utilisant des surfa
es NURBS (non-uniform rational B-spline). Après, on va travailler sur

la génération des tétraèdres à partir du maillage, a�n d'in
lure la tête dans la simulation

numérique. De 
ette manière, pouvoir simuler en tenant en 
ompte du volumen et de la

déformation de la tête foetale en passant pour le 
anal d'a

ou
hement. Ensuite, on montrera

la mise en pla
e de 
apteurs pour déterminer les a
tions et les for
es exer
ées par les mains

ou les for
eps sur la tête foetale du simulateur haptique.
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Figure 1 � Ar
hite
ture du projet SAGA [9℄.
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2 Traitement des �
hiers du maillage à NURBS

Le projet SAGA, spé
i�quement la partie liée au modèle numérique travaille ave
 des �
hiers

du maillage de la tête foetale qui sont utilisés a�n de simuler l'stru
ture physique et de

représenter divers 
omportements physiques. En vue de 
ela, nous avons besoin d'obtenir un

maillage propre et fa
il à utiliser. De même, l'idée est de faire une 
onversion à tétraèdres et

de 
ette manière, simuler le volumen et la déformation de la tête foetale en passant pour le


anal d'a

ou
hement.

Pour 
ette raison, dans 
e 
hapitre, on va montrer di�érentes méthodes de traitement des

images en utilisant les logi
iels 3DSMax et Rhino
eros et les di�
ultés trouvées ave
 
haque

méthode.

2.1 3DS Max 2015

I
i, on va montrer le pro
essus né
essaire pour la 
onversion des �
hiers ave
 les extensions

.obj et .wrl, en utilisant le logi
iel 3DSMax Studio 2015. (Les �
hiers .msh ne peuvent pas

s'ouvrir ave
 3DSMax).

3DSMax sera utilisée ave
 une li
en
e étudiante ave
 une validité de trois ans. De 
ette

manière, on pourra travailler sans sou
is. D'autre 
�te, 3DSMax est seulement disponible

sur le système d'explotation Windows.

2.1.1 Aménagement du maillage

1. Ouverture Fi
hier .WRL :

En premier lieu, on doit ouvrir 3DSMax. Ensuite on doit 
hoisir l'option Import dans

le menu qui se trouve dans la partie supérieure à gau
he, 
omme le montre la �gure

2 
i-dessous. Immédiatement, on doit séle
tionner Import (Non− native �le formats

into 3ds Max ). Cette a
tion permet de séle
tionner le �
hier à importer ave
 les ex-

tensions .obj et .wrl, entre autres options.

On a utilisé le �
hier appellé foetal − head − 4466.wrl pour montrer la pro
édure

suivie. Nous 
hargeons le �
hier et une fenêtre apparaît, 
omme le montre la �gure 3.

Il y a trois options :

� Reset s
ene : Cette option e�a
e les s
ènes antérieures, a�n d'éviter le mélange

ave
 le �
hier à importer.

� Turn to 3DS Coordinates : Si nous 
hoisissons 
ette option, on utilisera les


oordonnées natives du 3DSMax, sinon, le logi
iel maintiendra les 
oordonnées du

�
hier original.

� Create Primitives : Cet outil permet d'utiliser les fon
tions primitives du 3DSMax

et aussi, de prendre les textures. Sinon, 3DSMax transformera l'objet dans un
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Figure 2 � Importer des �
hiers en utilisant 3dsMax 2015.

Figure 3 � Option pour importer un �
hier .wrl dans le logi
iel 3DSMax 2015.

maillage triangulaire.

On a laissé toutes les options séle
tionnées et �nalement on a 
hoisi OK.

3DSMax donne une fenêtre ave
 quatre sous-fenêtres (Figure 4) qui permettent de

travailler ave
 l'objet dans di�érents vues et perspe
tives.

2. Résolution : Nombre de polygones et triangles :

Il faut que nous observions le nombre de polygones et triangles que nous avons, a�n

d'analyser si 
ela est né
essaire de 
hanger la résolution de notre objet. On peut voir

les statistiques que montre 3DS Max 2015. On 
hoisit le symbole + dans n'importe

quelle fenêtre. Ensuite, nous 
her
hons l'optionXview−Show Statisti
s. Et on pourra
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Figure 4 � Espa
e de travail dans le logi
iel 3DSMax 2015.

voir le numéro des polygones, triangles et vertex, 
omme le montre la �gure 5.

Alors, il est fondamental que nous travaillions ave
 moins de vertex et qu'on réduise

Figure 5 � Vue Perspe
tive ave
 le numéro de polygones, triangles et vertex.

le nombre de polygones ou triangles. Pour 
ette raison, on va utiliser l'outil Multires.

En premier lieu, on doit séle
tionner la tête et sur le 
�té droit, on pourra voir une

fenêtre ave
 le nom de l'objet et le type du format de l'image. Dans notre 
as, il

s'agit d'un maillage éditable. Après, dans la partie Modi�er List, il y aura une liste

déroulante, on doit 
her
her Multires, illustrée par la �gure 6.

L'outilMultires montrera une liste des paramètres à modi�er en fon
tion des besoins.
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Figure 6 � Modi�
ateur Multires dans 3DSMax 2015

Par rapport aux paramètres de la résolution, il montre les variables suivantes :

� Vert Per
ent : Correspond au nombre des vertex de l'objet modi�é par rapport

au nombre total de vertex du maillage d'origine.

� Vert Count : C'est-à-dire le numéro total de vertex de l'objet modi�é.

� Max Vertex :Permet de voir le nombre des vertex du maillage original auquel

nous appliquons Multires.

� Fa
e Count : Montre le nombre de fa
es.

� Max Fa
e : Indique le nombre maximal de fa
es.

Ces valeurs sont automatiquement mises à jour, quand nous 
hangeons un paramètre.

D'autre part, dans la se
tion de génération des paramètres, on peut trouver les options

suivantes :

� Vertex Margin : Si l'option est a
tivée, Multires va fusionner les vertex de tous

les objets que 
omposent le maillage.

� Boundary Metri
 : Cette option permet de mélanger les frontières des toutes

les éléments adja
ents qui 
omposent l'objet.

� Maintain Base Verti
es : Cet outil permet de 
onserver les vertex qui sont

la base de l'objet, a�n de maintenir la stru
ture, même quand la résolution est

diminuée. Il est très important de savoir quaprès de la diminution de la résolution,

les objets peuvent être mé
onnaissables.

� Multiple Vertex Normals : Il permet la génération de plusieurs normales. Elles

sont appliquées dynamiquement 
omme les 
hangements de résolution de sommet.

� Crease Angle : Il permet une variation de l'angle des normales entre 0 et 180.

Et seulement, il est a

essible si l'option antérieure est a
tivée.

Finalement, on peut 
hoisir l'option Generate, a�n de générer l'objet ave
 les para-
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mètres que nous avons 
hoisi.

Pour les exemples suivants, on a séle
tionné quelques vertex, a�n de garantir la ré-

du
tion dans 
es zones. Dans la �gure 7, vous pouvez voir le pro
essus de rédu
tion

de polygones.

Dans la �gure 8, on présente le nez et les oreilles séle
tionnées 
omme vertex base.

Figure 7 � Gau
he : tête originale ave
 les fontanelles et les oreilles séle
tionnés. Droit : tête

ave
 une rédu
tion de 50 pour 
ent de polygones.

Après la rédu
tion en polygones, 
'est né
essaire de garder les 
hangements faits.

En premier lieu, on doit 
ombiner notre objet Editable Mesh ave
 l'outil Multires.

Pour 
ette raison, on utilise l'option Collapse All (Figure 9) .

On a fait 
li
k droit, sur Multires et on 
hoisit l'option Collapse All.
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(a) Tête originale ave
 le nez et les oreilles séle
-

tionnées.

(b) Tête ave
 une rédu
tion de 50 pour 
ent de

polygones

(
) Tête ave
 une rédu
tion de 25 pour 
ent de

polygones

(d) Tête ave
 une rédu
tion de 15 pour 
ent de

polygones

Figure 8 � Di�érentes redu
tions en utilisant l'outil Multires et Vertex base

Figure 9 � Menu Collapse All dans le logi
iel 3DS Max 2015.
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2.1.2 Méthode 3DSMax

Le but �nal est de faire une 
onversion de format .obj, .wrl a .dae, a�n de pouvoir travailler

ave
 surfa
es NURBS et de générer des tétraèdres. On va 
ommen
er en suivant les pas sui-

vants qui se montrent, en utilisant le logi
iel 3DSMax [10℄, a�n d'obtenir un �
hier ouvrable

dans n'importe quel logi
iel Collada Editor (Utilise le format .dae).

1. Conversion Editable Mesh -> Editable Pat
h :

On va garder le �
hier en format .max (3DSMax). Ensuite, on fera un 
hangement

dans le type d'objet. On doit rappeler que nous sommes en train d'utiliser un format

type Editable mesh. Et pour nos besoins �naux, on doit faire une 
onversion au format

Editable Pat
h.

On va séle
tionner Editable Mesh, on fait 
li
k droit et après (Figure 10 ), on peut


hoisir l'option Editable Pat
h.

Figure 10 � Conversion Editable Mesh to Editable Pat
h dans le logi
iel 3DS Max 2015.

2. Conversion Editable Pat
h : -> NURBS

Finalement, on fait la même pro
édure, pour e�e
tuer le 
hangement jusqu'au format

NURBS. On va séle
tionner Editable Pat
h, on fait 
li
k droit et après, on peut 
hoisir

l'option NURBS, 
omme le montre la �gure 11. Dans la �gure 12, se montre la tête

foetale dans le format NURBS. Pour obtenir 
ette �gure, il faut que le nombre de

polygones soit le plus petit possible a�n d'éviter que le logi
iel 3DSMax ne soit pas


apable de faire la 
onversion NURBS.

3. Exporter le �
hier en format .dae (OPENCOLLADA)

Maintenant, on peut exporter notre tête foetale a�n d'utiliser le modèle dans un en-

vironnement haptique. Pour 
ette raison, nous allons exporter en utilisant le format

OPEN COLLADA .dae.

En premier lieu, on doit télé
harger l'outil que se trouve dans la page o�
ielle

(http://www.open
ollada.org/). Cet outil permettra que 3dsMax garde nos ar-


hives de manière 
orre
te. Nous devons télé
harger le �
hier ColladaMaxNew.dle

http://www.opencollada.org/
http://www.opencollada.org/
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Figure 11 � Conversion Editable Pat
h to NURBS dans le logi
iel 3DS Max 2015.

Figure 12 � Tête foetale dans le format NURBS.



2.1 3DS Max 2015 11

(qui mar
hera seulement sur Windows), et on doit garder l'ar
hive dans le dossier

�Plugins�. La fois suivante que nous utilisions 3ds Max, l'outil 
ollada sera dispo-

nible.

Pour faire l'exportation du �
hier, simplement on doit aller au menu prin
ipal et 
hoi-

sir l'option Exporter-(Non-native �le formats from the 
urrent 3ds Max S
ene).(Figure

13 )

3DS Max nous montrera une fenêtre des paramètres a�n de bien exporter notre objet.

Figure 13 � Exporter des �
hiers au format OPEN Collada en utilisant 3dsMax 2015.

Les paramètres se montrent dans la �gure 14.

Il s'agit des trois zones :

Figure 14 � Paramètres d'exportation OPEN Collada en utilisant 3dsMax 2015.

� Standards Options : Dans la première partie, nous trouvons quatre options :

� Bake Matri
es : Cet option permet la transformation de 
haque noeud de la

s
ène et de leurs animations que seront exportées 
omme matri
es.
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� Relative Paths : En utilisant 
ette propriété, on peut garder les images liées

aux textures en utilisant un 
hemin relatif, a�n d'éviter les sou
is.

� Copy Images : 
opiera tous les �
hiers de texture dans le dossier � Images �

au-dessus de votre dossier de .DAE.

� Export : User de�ned properties.

� Geometry : I
i, on observe quatre options, aussi :

� Normals : Permet de faire l'exportation des normales du maillage.

� Triangulate : Permet la division du maillage en triangles.

� In
lude XRefs.

� Tangents/Binormals : Exportez les tangentes de géométrie et binormals pour

toutes les données du maillage, aussi bien que leurs indi
es dans la rédu
tion

en mosaïque de maille.

� Animation : Dans 
ette zone, il y a la possibilité de gérer l'animation de la s
ène

et de faire l'exportation.

Dans la �gure 15, vous pouvez voir la tête foetale en utilisant un logi
iel qui permet

de voir les �
hiers ave
 extension .dae.

Figure 15 � A�
hage tête foetale dans le format dae

2.1.3 Di�
ultés dans la 
onversion en utilisant 3dsMax

En utilisant le logi
iel 3DS Max 2015 d'Autodesk, on peut travailler de manière fa
ile quand

on utilise des maillages polygonaux. Cependant, l'outil de 
onversion de maillages polygonaux

a�n d'obtenir NURBS n'est pas bon.

I
i, on montre les prin
ipales in
onvenients :

� On doit réduire le nombre de polygones et même il y a des o

asions où la tête a

perdu ses 
ara
téristiques physiques.

� 3DS Max ne peut pas 
réer de NURBS à partir du maillage, par 
ontre, on doit faire

une 
onversion a Editable Pat
h et 
e pro
essus 
omplique le traitement du maillage.



2.2 Rhino
eros 5.0 13

� Le NURBS que génère 3DS Max n'est pas exploitable. Il génère un maillage en mo-

saïque à partir des polygones originaux. Finalement, nous avons beau
oup de points

à travailler.

2.2 Rhino
eros 5.0

Ensuite, on va montrer le pro
essus né
essaire a�n de réaliser la 
onversion des �
hiers ave


les extensions .obj et .stl en utilisant le logi
iel Rhino
eros 5.0 2015. Il y a la possibilité de

télé
harger une version trial de 90 jours pour 
e logi
iel. De même, le logi
iel est disponible

sur le système d'explotation Windows et Ma
.

2.2.1 Aménagement du maillage

1. Ouverture Fi
hier .STL

En premier lieu, on doit ouvrir Rhino
eros 5.0. Ensuite on doit 
hoisir l'option Import

dans le menu qui se trouve dans la partie supérieure à gau
he, 
omme le montre la

�gure 16 
i-dessous.

Par la suite, on doit 
hoisir le format du �
hier à importer. Rhino permet de travailler

Figure 16 � Importer des �
hiers en utilisant Rhino
eros 2015.

ave
 les extensions .stl, .obj et .wrl, entre autres options.

On a utilisé le �
hier appellé foetal − head − 4466.stl pour montrer la pro
édure

suivie. Nous 
hargeons le �
hier et la fenêtre des paramètres d'importation apparait,


omme le montre la �gure 17.

Il permet de 
hanger les options suivantes :

� Weld Angle : Cette option permet de 
hoisir l'angle de soudure du maillage.
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Figure 17 � Options d'importation �
hiers ave
 formats .stl dans le logi
iel Rhino.

� Split disjoint meshes : S'il y a des problèmes dans le maillage en 
hoisissant


ette préféren
e, le logi
iel détermine si les piè
es disjointes d'une maille seront

automatiquement partagées sur l'importation.

� STL Model : Si le �
hier .stl a des unités, Rhino permet de visualiser et 
hoisir

les unités appropriées.

� Always use these settings : Et �nalement, on a le 
hoix de sauvegarder les


on�gurations pour les importations pro
haines.

On a utilisé les préféren
es montrées dans la �gure 17, et Rhino
eros nous o�re

une interfa
e ave
 4 vues possibles 
omme la �gure 18 illustre et selon l'aide de

Rhino
eros[11℄.

Figure 18 � Espa
e de travail dans le logi
iel Rhino
eros 2015.

2. Résolution : Nombre de polygones et triangles
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Comme dans le 
as antérieur ave
 3DS Max, on a beau
oup de polygones et nous

avons besoin de diminuer le nombre de points a�n de travailler fa
ilement ave
 le

maillage. Rhino permet de 
onnaitre les propriétés de l'objet. Mais, on doit analyser


haque maillage, a�n de dé
ider si 
'est né
essaire faire la rédu
tion ou pas.

Pour observer les 
ara
téristiques prin
ipales, on séle
tionne le Menu View et après

on 
hoisit l'option Display Options. Ensuite, la fenêtre ave
 les options de visibilité

sont montrées 
omme le montre la �gure 19 
i-dessous.

L'utilisateur peut 
hoisir les options qu'il veut voir, dans notre 
as, on a séle
tionné

Figure 19 � Préféren
es de visibilité Rhino
eros 2015

toutes les possibilités qui sont soulignées en utilisant le re
tangle orange de la �gure

19.

Puis, on pourra voir toutes les 
ara
téristiques, dans le menu Properties qui se trouve

à droite dans la zone de travail de Rhino. On 
hoisit Details et immédiatement une

fenêtre ave
 les des
riptions de l'objet apparait 
omme illustré dans la �gure 20.

Dans 
e tableau, on peut voir :

� Le numéro de vertex : 4596

� Le numéro de polygones : 8928

En utilisant 
es données, on va 
ommen
er la rédu
tion de nombre de polygones,

triangles et vertex. En premier lieu, on va séle
tionner le menuMesh. Ensuite, l'option

Mesh Edit Tools -> Collapse -> Redu
e Vertex Count. De manière optionnel, on peut

séle
tionner le menu Mesh. Ensuite, l'option Mesh Edit Tools -> Redu
e Mesh.

Il s'agit d'un autre 
hemin qui permet de réduire le maillage. Après, on peut voir la

fenêtre de la �gure 21.
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Figure 20 � Propriétés du maillage dans le logi
iel Rhino
eros 2015

La rédu
tion peut être faite en 
hangeant le nombre de polygones, par pour
entage

Figure 21 � Options de rédu
tions de polygones dans le logi
iel Rhino
eros 2015

ou uniquement restreindre de la rédu
tion aux polygones plans.

De même, on peut 
hoisir le type de rédu
tion que l'on veut : une rédu
tion rapide

ou une rédu
tion pré
ise.

Les di�éren
es sont les suivantes :

� Rapide : La rédu
tion est réalisée plus aléatoirement, ave
 moins de 
al
ul, 
e qui

permet d'être plus rapide.

� Pré
ise : La rédu
tion produit le moins possible d'artefa
ts visibles. Ce
i implique

plus de 
al
ul et don
 une vitesse plus lente.

On va 
ommen
er la rédu
tion de 8928 polygones jusqu'à 4464 polygones. De 
ette

façon, on obtiendra une rédu
tion 
omme l'illustre la �gure 22.
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Figure 22 � Rédu
tions de polygones e�e
tués à la tête foetale sur le logi
iel Rhino
eros

2015.

2.2.2 Méthode en utilisant Rhinoresurf

1. Conversion Maillage à surfa
es de manière automatique :

En premier lieu, pour faire la 
onversion à Nurbs, 
'est né
essaire que nous télé
har-

gions le plugin s'appelle Rhino Resurf depuis sa page o�
ielle. Il y a un trial ave


une durée de 20 jours.

Le premier pas est 
hoisir le maillage de la tête foetale, dans notre 
as. Après, nous

allons 
her
her le Menu Rhino Resurf qui va apparaître depuis l'installation du plugin.

Du 
oup, on va séle
tionner le menu Rhino Resurf -> Automati
 surfa
es generation

from mesh. Puis, Rhino
eros montrera la �gure 23.

De 
ette manière, le logi
iel nous donnera la fenêtre de paramétrage pour la généra-

tion d'un réseau de 
ourbes et pour la surfa
e (Figure 23). Ensuite, il faut que nous


hoisissions l'option Curve Network et de 
ette façon, on va obtenir un réseau des


ourbes 
omme le montre la �gure 24 
i-dessous.

Le pas suivant est de véri�er 
haque 
ourbe, a�n de s'assurer qu'il n'y aura au
un

problème dans la génération du surfa
e Nurbs. Par exemple, l'idée est de trouver les


ourbes adou
ies pour fa
iliter la 
onversion. S'il y a des problèmes, on doit utiliser

l'outil Smooth Curve. On va montrer le pro
essus que on a suivi pour améliorer la


ourbe de la �gure 25.

Pour 
orriger 
es erreurs, on séle
tionnera la 
ourbe qui a le problème et après on

utilisera l'option Smooth Curve du menu Automati
 surfa
e generation qui montre la

�gure 23. On va répéter le pro
essus ave
 toutes les 
ourbes qui ont le même problème.

S'il y a besoin de 
onstruire quelques lignes, on peut utiliser la 
ommande Polyli-

neOnmesh. Cet outil est fa
ile d'emploi et il exige seulement une dé
laration du point

http://www.resurf3d.com/products.htm
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Figure 23 � Fenêtre de génération automatique des 
ourbes et surfa
es dans le logi
iel

Rhino
eros 2015.

Figure 24 � Réseau des 
ourbes dans le maillage de la tête foetale dans le logi
iel Rhino
eros

2015.

de début et de la �n de polyline.

Quand le réseau des 
ourbes est adéquat, on va 
réer la surfa
e en suivant 
e pro
essus.

Il faut que nous séle
tionnions le nombre de point de 
ontr�le (Control Point) dans

la fenêtre de la �gure 26 et après, on va séle
tionner l'option Create Surfa
e.
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Figure 25 � Problème dans une 
ourbe du maillage de la tête foetale dans le logi
iel Rhi-

no
eros 2015.

Quand, nous avons terminé la 
réation de la surfa
e, on peut 
hanger la visibilité des

Figure 26 � Génération automatique des surfa
es dans le logi
iel Rhino
eros 2015.

autres 
ou
hes de l'objet, dans le menu Layers qui se trouve dans la partie droite de

la zone de travail de Rhino
eros. De 
ette façon, on peut voir de manière pré
ise la

surfa
e, 
omme le montre la �gure 27.
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Figure 27 � A�
hage des surfa
es dans le logi
iel Rhino
eros 2015.

De même, nous pouvons manipuler les points de 
ontr�le en utilisant la 
ommande

PointsOn, le bouton F10 ou séle
tionnant le Menu Edit-> Control Points -> Control

Point On et �nalement, on obtiendra les points de 
ontr�le de notre surfa
e 
omme

illustré la �gure 28 
i-dessous.

Ave
 
et outil, nous pouvons faire des 
hangements sur notre surfa
e fa
ilement. Pour

Figure 28 � A�
hage des points de 
ontr�le de la surfa
e dans le logi
iel Rhino
eros 2015.
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ne pas montrer les points de 
ontr�le, il su�t de taper F11.

2. Exportation du maillage à format .stl

Par la suite, on fera l'exportation du �
hiers, en utilisant le format .stl . On doit

générer un maillage de polygones qui peut être exporté en utilisant le format .stl

Le premier pas est de 
onstruire le maillage de polygones en utilisant l'outil Polygon

Mesh. Rhino
eros va 
réer un maillage en prenant en 
ompte le Fitting Surfa
e, que

nous avons 
réé dans la se
tion antérieure (Figure 29). Ensuite, on va au menu File

Figure 29 � A�
hage de Polygon Mesh dans le logi
iel Rhino
eros 2015.

-> Export sele
ted. Après, on 
hoisit le maillage (ligne rouge dans 
e 
as) dans la zone

de travail. Rhino
eros nous montrera les fenêtres suivantes (Figure 30), 
es options

nous permettent d'exporter le maillage ave
 les paramètres dont nous avons besoin.

Figure 30 � Paramétrage de lexportation en utilisant le format .stl dans le logi
iel Rhino
eros

2015.
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2.2.3 Méthode en utilisant Cage Edit

Il y a d'autres 
hemins pour obtenir un maillage manipulable rapidement. Il s'agit d'utiliser

le maillage original foetal − head − 4466 dans le format .stl. On peut suivre les mêmes

instru
tions qu'ont été montrées dans la se
tion Aménagement du maillage (1.2.1).

D'abord, on séle
tionne le menu Transform -> Cage Editing -> Cage Edit 
omme illustré

dans la �gure 31. Rhino nous demande de séle
tionner le maillage à traiter (Sele
t Captive

Figure 31 � Menu Transform Rhino
eros 5.0

Objets). Après, on doit 
hoisir un objet pour faire le 
ontr�le entre les options suivantes

Boundingbox, Line, Re
tangle, Box. Dans la �gure 32, on observe les di�érentes options apli-

quées sur la tête foetale.
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(a) Cage Boundingbox (b) Cage Line

(
) Cage re
tangle

Figure 32 � Options Cage Edit
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Chaque option permet d'établir des paramètres de 
réation. Il y des a
tions par défaut,

mais il est possible de 
hanger selon les besoins. De même, on peut modi�er les options

Deformation et PreserveStru
ture qui nous fournissent les possibilités suivantes :

� Déformation :

� Pré
ise : La mis à jour est lente, mais les surfa
es peuvent être plus denses lorsque

les objets déformés sont optimisés.

� Rapide : Cette option génere une surfa
e ave
 moins de points de 
ontr�le.

� Conserver la stru
ture :

Elle permet de 
onserver le maillage ou pas. Par défaut, 
et outil montre l'option No.

De 
ette façon, on peut faire des modi�
ations et des déformations pré
ises.

La stru
ture de la tête foetale que nous avons, nous donne la possibilité de travailler ave
 une


age de type boîte de 
ontour (Bounding box ). Désormais, on montrera les paramètres que

nous avons en 
hoisissant 
ette option. En premier lieu, on �xera le système de 
oordonnées.

Il y a trois options :

� CPlane

� World

� 3Point

Le système de 
oordonnées, le plus utilisé et 
elui qui se trouve par défaut est Cplane.On va

séle
tionner 
e système.

Après, on doit 
hoisir la quantité de points et le degré de la 
age dans 
ha
une des trois

dire
tions. Rhino montre par défaut les paramètres suivants :

Cage points :

� XPointCount=4

� YPointCount=4

� ZPointCount=4

� XDegree=3

� YDegree=3

� ZDegree=3

Cependant, vous pouvez modi�er la quantité de points selon vos besoins. Dans 
e 
as, il y

a seize points de 
ontr�le par 
haque 
�té. Et �nalement, on doit 
hoisir la région que nous

voudrions modi�er. I
i, Rhino nous montrera les options suivantes :

� Global

� Lo
al

� Other

Les résultats �naux se montrent dans la �gure 33-a. Ensuite, on peut faire des modi�
ations

en utilisant les points de la 
age, 
omment le montrent la �gure 33-b.

Quand on aura �ni les modi�
ations du maillage en utilisant la 
age, on va suivre les indi-


ations qui ont été montrées dans la Se
tion 1.2.2.1 Exportation du maillage à format .stl.
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(a) Cage Boundingbox (b) Modi�
ations en utilisant les points de la


age

Figure 33 � Outil Cage Edit de logi
iel Rhino
eros

2.2.4 Di�
ultés dans la 
onversion en utilisant Rhino
eros

La 
onversion du maillage en utilisant Rhino o�re beau
oup des options a�n d'obtenir une

surfa
e. Cependant, il y a le risque d'obtenir des surfa
es qui ont les normales inversées. Ce

problème provoque des sou
is dans les traitements suivants, par exemple, dans la 
réation

de tétraèdres. C'est toujours né
essaire que nous 
hangions les orientations des normales

en utilisant un logi
iel 
omme Meshlab. Nous travaillerons ave
 
et outil dans le 
hapitre

suivant.
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3 Generation des tétraèdres à partir du maillage

Après de 
e pro
essus, on peut travailler ave
 le maillage de polygones généré a�n de


onstruire des tétraèdres.

3.1 Meshlab

Le logi
iel Meshlab nous aidera ave
 l'aménagement du maillage après le traiement ave
 le

logi
iel Rhino
eros. Meshlab est disponible sur les systèmes d'exploitation Windows, Linux

et Ma
. [12℄

3.1.1 Aménagement du maillage

I
i, on va utiliser le �
hier .stl de Rhino
eros. Nous allons faire un nettoyage du �
hier . stl

en utilisant le logi
iel Meshlab. L'idée est de garantir que toutes les triangles sont fermés et

qu'il n'y aura pas de surfa
es ouvertes. Cette pro
édure nous aidera après dans la génération

des tétraèdres. I
i, on va séle
tionner le menu File -> Import Mesh, on 
her
hera le �
hier à

traiter et on appuiera sur Ouvrir.

Meshlab nous montrera la fenêtre suivante( Figure 34 ). Dans l'espa
e de travail, de manière

Figure 34 � Paramétrage pour l'importation des �
hiers .stl dans le logi
iel Meshlab.

immédiate, notre maillage apparaitra 
omme le montre la �gure 35.

Figure 35 � Tete foetale dans le logi
iel Meshlab.
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3.1.2 Résolution des problèmes

Il y aura quelques fois des erreurs 
omme le montre la �gure 36. On peut voir qu'il y a un

sou
i ave
 la majorité des triangles. Les triangles de 
ouleur noire ont les normales de leurs

fa
es à l'intérieur et les triangles de 
ouleur grise ont les normales de leurs fa
es à l'extérieur.

Pour résoudre 
et in
onvénient, on peut utiliser l'option de 
orre
tion des normales de

Figure 36 � Erreurs d'orientation des normales du maillage.

Meshlab. Nous la trouverons dans le menu Filters->Normals, Curvatures and Orientations

->Invert Fa
es Orientations (Figure 37) .

Figure 37 � Changement des orientations des normales dans le logi
iel Meshlab
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3.1.3 Exportation du maillage à format .stl

D'abord, on fera une exportation en utilisant le format .stl. Mais dans 
e 
as, on va garder

sans le 
odage binaire. On 
her
he le menu File -> Export Mesh as. Et après, on suivra les

paramétrages qui se montrent dans la fenêtre suivante (�gure 38).

Figure 38 � Options pour faire l'exportation en utilisant le format .stl dans le logi
iel

Meshlab.

3.2 Netgen 5.0

3.2.1 Conditionnement du maillage, format .stl :

En premier lieu, on a besoin d'autre logi
iel qui nous permet de faire la 
onstru
tion de

tétraèdres. Pour 
ette raison, on va travailler en utilisantNetgen 5.0. Ce logi
iel est disponible

sur les systèmes d'exploitation Windows, Linux et Ma
. Netgen nous donne l'option d'ouvrir

des �
hiers ave
 les suivants formats .igs, .iges , .stl, .stlb .geo et d'autres. [13℄ Quand, on

ouvrira Netgen, on ira au Menu File-> Load Geometry. Ensuite, on va 
hoisir le �
hier

.stl.(Figure 39)

3.2.2 Résolution des problèmes

Il y aura quelques fois des erreurs 
omme le montre la �gure 36.
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Figure 39 � Maillage de la tête foetale dans le logi
iel Netgen 5.0

Figure 40 � Maillage de la tête foetale dans le logi
iel Netgen 5.0
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La géométrie, de la �gure 40, a les 
ara
téristiques suivantes :

� Les triangles brillants ont les fa
es à l'extérieur.

� Les triangles opaques ont leurs fa
es à l'intérieur.

Le deuxième groupe provoquera des problèmes dans la génération des tétraèdres. Il faut

qu'on 
hange l'orientation des triangles. (Si nous ne l'avons pas fait en utilisant Meshlab).

On utilisera l'outil STL INFO de Netgen pour 
onnaitre l'état initial du maillage. De même,

on peut voir la sortie de la 
onsole de Netgen 
omme illustré dans la �gure 41. Clairement,

Figure 41 � STL INFO et l'info dans la 
onsole dans le logi
iel Netgen 5.0

il y a une erreur dans notre maillage. Pour 
orriger les triangles, nous utiliserons l'outil

STL DOCTOR qui vient ave
 Netgen. On va 
ommen
er en 
hoisissant la possibilité de

séle
tionner des triangles en faisant double 
li
k dans le menu General de STL DOCTOR.

Ensuite, on séle
tionnera les triangles à 
hanger un pour un dans l'espa
e du travail et puis,

on va 
hoisir le menu Edit Topology.

Ce menu permet de voir les in
onsistan
es par rapport aux triangles du maillage (option

mark in
onsistent triangles) et aussi il permet de modi�er l'orientation des triangles. On

utilisera l'option Orient after sele
ted trig (Figure 42).

Dans la suite, Netgen nous montrera la tête foetale, 
omme le montre la �gure 
i-dessous.

De même, on peut regarder l'état du maillage, a�n de 
onstater que le maillage est bon

(Figure 43). On peut fermer la fenêtre de STL DOCTOR.

S'il y a d'autres sou
is, il y a d'autres outils de STL DOCTOR qui permettent de 
orriger

les normales. (Figure 44)

3.2.3 Génération des tétraèdres à partir du maillage :

Une fois qu'on aura le maillage sans au
un sou
i. On va suivre la pro
édure suivante :

1. Génération du maillage :

On doit séle
tionner le menu Mesh-> Generate Mesh.

2. Véri�
ation de qualité :

On doit 
hoisir dans le menu Mesh-> Mesh Quality.
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Figure 42 � STL DOCTOR dans le logi
iel Netgen 5.0

3. Analyse de Géométrie :

On doit 
hoisir dans le menu Mesh-> Analyse Geometry.

4. Generation Surfa
e du maillage :

Puis, on 
hoisira le menu Mesh-> Mesh Surfa
e

5. Optimisation de Surfa
e :

Après, 
'est né
essaire de faire une optimisation de surfa
e en a

édant depuis le menu

Mesh-> Optimize Surfa
e.

6. Generation Volume :

Finalement, on va 
onstruire le volume pour notre maillage en utilisant le Mesh->

Mesh Volume.

7. Optimisation Volume :

Pour bien �nir ave
 notre volume, on fera la dernière optimisation a travers duMesh->

Optimize Volume.
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Figure 43 � Maillage de la tête foetale après les 
orre
tions en utilisant l'outil STL DOCTOR

dans Netgen 5.0

Figure 44 � D'autres outils STL DOCTOR dans le logi
iel Netgen 5.0
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Dans la �gure 45, vous pouvez voir la sortie de la 
onsole pour 
haque opération faite.

Figure 45 � Sortie de la 
onsole Netgen pour toute la pro
edure de génération des tétraèdres

3.2.4 Exporter du maillage en utilisant le format gmsh2

Après avoir suivi les pas antérieurs, on doit selé
tionner le format 
orre
t pour faire l'expor-

tation de notre volumen tétraédrique.

On doit 
her
her dans le Menu File->Export �le Type->Gmsh2 Format., 
omme le montre

la �gure 46. Ensuite, vous pouvez 
hoisir l'option export Mesh de Menu File,et vous devez

selé
tionner un nom pour votre maillage et le pro
essus sera terminé. Dans la �gure 47 , on

peut voir la tête foetale après la génération des tétraèdres.
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Figure 46 � Exporter en utilisant le format gmsh2 sur Netgen

Figure 47 � Tête foetale après de la génération des tétraèdres
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3.2.5 Cara
téristiques du format gmsh2

Le format .gmsh2 de notre tête foetale a les 
hamps suivants :

� Information générale du maillage :

$MeshFormat

2.2 0 8 -> Version - type de fi
hier - taille du fi
hier

$EndMeshFormat

� Information spé
i�que selon le 
as (Nodes, elements, Region names, periodi
 relations

and post-pro
essing datasets)

$Nodes

5 
inq noeuds dans le maillage:

1 0.0 0.0 0.0 noeud #1: 
oordinates (0.0, 0.0, 0.0)

2 1.0 0.0 3.0 noeud #2: 
oordinates (1.0, 0.0, 3.0)

3 1.0 4.0 7.0 et
.

4 0.0 1.0 0.0

5 3.0 0.0 1.0

$EndNodes

$Elements

2 deux éléments

1 4 2 99 2 1 2 3 4 Numéro d'élément - type d'élément

- nombre de tags - list de noeuds

2 4 2 101 2 21 8 16 3 Elément #2: type 4 (tetraedron), physi
al 101,

elementary 2, nodes 21 8 16 3

$EndElements

Les éléments peuvent être de di�érents types. Par example :

� Type 1 : Noeud type ligne

� Type 2 : Noeud type triangle

� Type 3 : Noeud type quadrangle

� Type 4 : Noeud type tetradron
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4 Dete
tion des pressions exer
ées sur la tête foetale

Pour 
ertains a

ou
hements, il faut que les méde
ins utilisent des outils d'extra
tion ins-

trumental qui permettent de saisir la tête foetale pendant la naissan
e.

Il y a deux outils les plus 
onnus : les for
eps et la ventouse.

Le for
eps est 
onstitué par deux bran
hes qui sont introduites de manière séparée. Ensuite,

quand les bran
hes sont bien pla
ées, le responsable de la manoeuvre peut les atta
her et les

arti
uler ensemble.

Dans la �gure 48, on peut voir les pas à tenir en 
ompte pour la mise en pla
e des bran
hes

du for
eps.

Figure 48 � Mise en pla
e du For
eps.[14℄

Cependant, il y a eu quelques 
ompli
ations en utilisant le for
eps, par exemple les �stules

et les dé
hirures vaginales et l'ex
ès de pression sur la tête foetale. Notre appli
ation a le but

de trouver et 
al
uler les for
es qui sont appliquées en utilisant le for
eps sur la tête foetale.

4.1 For
eps

Le for
eps est un outil utilisé depuis longtemps. On 
onsidère que l'inventeur est Monsieur

Peter Chamberlain, par
e qu'il a été la première personne à utiliser le for
eps en séparant les

bran
hes de la pin
e([15℄). De même, Monsieur Levret a modi�ée le for
eps de Chamberlain

([16℄) et il a 
rée la 
ourbure pelvienne dans les 
uillères de for
eps a�n de fa
iliter l'extra
tion

de la tête foetale et suivre le 
hemin pelvien. Après, Etienne Tarnier a amélioré le for
eps

de Levret en ajoutant un tra
teur qui a permis de mettre en valeur le dernier dessin et de


ette manière, les personnels de santé peuvent suivre la traje
toire de la tête foetale. ([16℄)
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À l'époque a
tuelle, il y a beau
oup des modèles de for
eps selon le pays, de l'é
ole de

Méde
ine et les traditions de la région. Il y a plusieurs variations par rapport aux for
eps.

Il y a des modèles ave
 les bras plus 
ourts que d'autres et il y a aussi d'autres modèles qui

vient ave
 tra
teur.

Dans la �gure 49, se montrent quelques modèles.

(a) For
eps Chamberlain. [17℄ (b) For
eps Levret. [18℄

(
) For
eps Tarnier ave
 tra
teur.[14℄ (d) For
eps Pajot. [19℄

Figure 49 � Modèles du for
eps.
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4.1.1 Séle
tion des for
eps

Dans les é
oles françaises et parti
ulièrement à Lyon, le for
eps le plus utilisé est le modèle

Levret. Cependant, 
e n'est pas fa
ile de trouver 
e modèle sur le mar
he. Pour notre appli-


ation, on a 
hoisi un for
eps type Pajot a�n de faire des preuves ave
 et de �xer les 
apteurs

sur la surfa
e des 
haque bran
he.

4.2 Capteurs de pression

Pour l'éxe
ution des mesures de pression et de la for
e appliquée sur la tête foetale, on a

dé
idé d'utiliser des 
apteurs qui permettent obtenir une valeur de pression quand le for
eps

fait 
onta
t ave
 la tête de nouveau-né.

4.2.1 Séle
tion des 
apteurs

Nous avons e�e
tué l'état de l'art par rapport aux 
apteurs a
tuels qui nous donnent la

possibilité de mesurer 
ette for
e. Parmi les 
apteurs, on peut trouver les 
atégories suivantes :

� Capa
itives : Le fon
tionnement des 
apteurs de type 
apa
itif est fondé dans le


hangement de la valeur de la 
apa
itan
e entre deux piè
es métalliques et un diéle
-

trique à l'intérieur du 
apteur. Normalement, les tailles des 
apteurs sont assez petites

et pour 
ette raison, les prix sont élevés.

� Piézorésistives : (FSR :For
e Sensing Resistor) D'autre 
�té, il y a les 
apteurs de

type résistifs qui 
hangent la valeur de la résistan
e par rapport à la pression exer
ée

sur la surfa
e du 
apteur. Il y a beau
oup de fournisseurs qui o�rent di�érentes options

selon la taille, la pression à mesurer, et
. Dans la �gure 50,on peut observer di�érents


apteurs FSR.

Figure 50 � Capteurs Piézorésistifs : FSR.

� Matri
ielles : Les 
apteurs de type matri
ielle sont parfaits pour les appli
ations

qui ont besoin de mesurer plusiers pressions à même temps. Également, les 
apteurs

sont 
onstruits en suivant un patron, et 
ela peut être une 
ontrainte pour notre

appli
ation, par
e que les 
apteurs de type matri
iel ne peuvent pas être 
oupés ou
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modi�és. Dans la �gure 51, on trouve un exemple d'un 
apteur matri
iel de Teks
an.

Figure 51 � Capteur matri
iel Teks
an

Entre les options, on a 
hoisi les 
apteurs de type résistif par
e qu'ils donnent les meilleures

prestations. Ils ne sont pas 
hers, ils sont �exibles et on peut travailler de manière intuitive

ave
 eux. Nous avons tenu en 
ompte des 
onsidérations suivantes :

� Le 
apteur doit être approprié pour notre appli
ation. (Cara
téristiques physiques)

� Le prix

� La fa
ilité pour l'exploitation des données.

4.2.2 Cara
téristiques des 
apteurs séle
tionnés

Les 
apteurs CP150 de fournisseurs IEE ont les 
ara
téristiques qui se montrent dans la

table 1 :

Taille 12 
m de diamètre

Gamme de pression optimale 0.007 à 7 bars

Résistan
e 10MWà 1kW

Pression maximum appliquée : 35 bars

Temps de montée du signal : 1à 2 ms

Table 1 � Cara
téristiques prin
ipales du 
apteur CP150 IEE

On doit rappeller que la pression est la for
e par unité de surfa
e. Il y a beau
oup d'unités

de mesure, selon le 
hamp d'appli
ation. Ensuite, vous pouvez voir les plus utilisées.
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� Pas
al (Pa) => 1 N / m^2

� Psi : => 6,894 X 10^3

� At : => 101325 Pa^2

� Bar : => 100.000 Pa

� mmHg : =>

� Torr :=> 133,322 Pa

Grâ
e aux 
onversions antérieures, on 
onnait la gamme de pression optimale du 
apteur en

tenant 
ompte du système interna
ional de mesure (SI) :

0.007 à 7 bars => 700 Pa (Nm/m^2) à 700000 Pa (Nm/m^2)

0.007 à 7 bars => 0.07 Nm/
m^2) à 70 Nm/
m^2)

4.2.3 Conditionnement des 
apteurs

Les 
apteurs que nous sommes en train d'utiliser sont de type FSR, et 
'est la raison pour

laquelle on peut 
onsidérer que leur fon
tionnement sera lié au 
hangement d'une résistan
e

quand on fait pression sur la surfa
e a
tive.

C'est fondamental, alors, de 
on
evoir un 
ir
uit qui permet de mesurer les 
hangements

de résistan
e qui varient entre 10kWet 1MW. La 
onsidération antérieure est fondée sur la


ourbe typique de 
omportement du 
apteur illustré dans la �gure 52.

Figure 52 � Courbe typique de 
omportement Capteur IEE. [20℄
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Nous avons deux options, qui se montreront ensuite :

1. Méthode Résistan
e Pull-down ou Pull-Up :

La première méthode pour 
onnaitre le 
hangement de résistan
e de notre 
apteur

est d'utiliser une simple résistan
e en 
on�guration Pull-down ou pull-up, 
omme sur

la �gure 53. L'in
onvénient est que si la résistan
e du 
apteur 
hange entre 1kWet

(a) Con�guration de résistan
e Pull-down. (b) Con�guration de résistan
e Pull-up

Figure 53 � Con�guration des 
ir
uits de mesure en utilisant résistan
es Pull-down et pull-

up

10 MW, une valeur de 10k ne sera pas 
omparable. De même, nous n'avons qu'une

variable à 
hanger, 
'est-à-dire un degré de liberté. Ainsi, la 
on
eption de 
ir
uit sera

limitée.

2. Bridge Wheatstone :

L'autre option est d'utiliser un pont de résistan
es dans une 
on�guration Wheats-

tone. Cette option permet de mesurer la résistan
e du 
apteur FSR en ajustant les

trois autres résistan
es. Dans 
e 
as, on a trois degrés de liberté pour notre 
on
ep-

tion. La 
on�guration Wheatstone est illustré 
i-dessous, sur la �gure 54.

Cette 
on�guration peut s'étudier en utilisant les lois de Kir
hho� ou de 
ontempler

le 
ir
uit 
omme deux bran
hes indépendantes, 
omme le montre la �gure 55 et la

notion des diviseurs de tension.
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Figure 54 � Con�guration de quatre résistan
es pour le pont Wheatstone

Figure 55 � Diviseurs de tension dans le pont Wheatstone



4.2 Capteurs de pression 43

En premier lieu, nous avons besoin de 
onnaitre la tension entre les bornes D et B. La

première bran
he 
orrespond au diviseur de tension des résistan
es R1 et R2. L'ex-

pression se montre dans l'équation 1.

VB1 = VCC •

R2

R1 +R2
(1)

De manière similaire, l'expression pour la bran
he qui 
orrespond aux résistan
es R3

et Rx (FSR) est a�
hé ensuite.

VB2 = VCC •

Rx

Rx+R3
(2)

Après, si nous joignons les équations (1) et (2) a�n d'obtenir une expression pour la

tension VDB. Nous obtiendrons l'équation suivante.

VDB = VCC •

(

R2

R1 +R2
−

Rx

Rx+R3

)

(3)

L'equation (3) sera la fon
tion de transfert de notre pont de Wheatstone et on va

l'utiliser pour désigner le 
ir
uit. En premier lieu, nous avons les 
onditions suivantes :

� VCC = 5V

� 1KW< RX < 10MW

� Il faut que

R2

R1+R2
> Rx

Rx+R3
, a�n de garantir toujours des tensions positives.

En tenant en 
ompte les 
onsidérations antérieures, on fera le design en étudiant les

variations de 
haque bran
he. On 
ommen
era ave
 la bran
he VB2. L'idée est de

trouver la meilleure résistan
e R3, qui donne la plage la plus large possible. Dans la

table 2, se montrent les variations par rapport à la tension dans la bran
he VB2.

Selon les plages obtenues, la valeur de la résistan
e R3 qui permet d'obtenir meilleures

R3
Rx

Rx+R3

1kW 0.63 - 0.99

5kW 0.33 - 0.95

10kW 0.17 - 0.909

15kW 0.119 - 0.869

20kW 0.092 - 0.833

22kW 0.089 - 0.891

33kW 0.05 - 0.75

47kW 0.041 - 0.68

50kW 0.039 - 0.666

70kW 0.029 - 0.587

100kW 0.019 - 0.508

Table 2 � Plan
he des variations de la fon
tion de la bran
he deux VB2, en 
hangeant la

résistan
e R3

résultats est 10kW, par
e qu'elle 
on
ède une variation entre 0.17 et 0.95. Cette plage
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garantie que la majorité des valeurs soient utilisées sans pertes dans les extrêmes

supérieures et inferieures. Le deuxième pas est faire que la fra
tion

R2

R1+R2
soit plus

grand que le limite supérieur de la bran
he deux VB2. C'est-à-dire,
R2

R1+R2
>0.909.

En utilisant les valeurs 
ommer
iales des résistan
es (Table 3), il faut que nous trou-

vions une paire adéquate.

1 1.2 1.5 1.8 2 2.2 2.7

3.3 3.9 4.7 5.6 6.8 8.2 9.1

Table 3 � Guide des valeurs 
ommer
iales des résistan
es

Après le 
al
ul, les valeurs des résistan
es R1 et R2 sont 1kWet 47kWrespe
tivement.

On doit mésurer les valeurs réelles des résistan
es qu'on va utiliser pour 
ha
un de


apteur a�n de 
onnaître le rapport de

R2

R1+R2
. Ensuite,dans la table 4, on montre les

valeurs mésures.

Résistan
e/Capteur S1 S2 S3 S4 S5 S6

R1 987W 981W 992W 990W 987W 991W

R2 45.8kW 46.3kW 46.2kW 46.3kW 46.3kW 46.3kW

R3 9.85kW 9.85kW 9.88kW 9.80kW 9.86kW 9.89kW

R2

R1+R2
0.9789 0.9792 0.9789 0.9790 0.9791 0.9790

Table 4 � Valeurs réelles des résistan
es du pont Wheatstone de 
haque Capteur.

3. Ampli�
ateur d'instrumentation ou de mesure :

Cette 
on�guration est utilisée a�n de traiter de petites signaux et de faire du 
ondi-

tionnement de signaux divers. Dans notre 
as, elle nous permettra de traiter et d'am-

pli�er le signal. Il y a di�érents types d'ampli�
ateur qui sont montrées ensuite.

Dans la �gure 56, vous pouvez observer trois 
on�gurations di�érentes. La première

se montre dans la �gure 56(a), il s'agit d'un s
héma qui utilise un ampli�
ateur

opérationnel et quatre résistan
es pour varier le gain du 
ir
uit. Cependant, 
e 
ir
uit

donne une impédan
e d'entrée basse provo
ant des 
hangements de 
ourant quand

nous 
onne
tons 
ertains dispositifs à l'entrée.
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(a) Ampli�er ave
 1 opamp. (b) Ampli�er ave
 2 opamps.

(
) Ampli�er ave
 3 opamps.

Figure 56 � Di�érentes 
on�gurations d'Ampli
ateurs d'instrumentation
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Par 
ontre, les �gures 56(b) et 56(
), montrent des 
on�gurations en utilisant deux

et trois ampli�
ateurs opérationnels, respe
tivement. Les deux 
ir
uits o�rent une

impédan
e d'entrée haute qui garantit que si nous 
onne
tons un dispositif à l'entrée,

le 
ourant ne 
hangera pas trop.

Nous avons 
hoisi, la 
on�guration qui utilise trois ampli�
ateurs opérationnels en

tenant 
ompte de deux raisons : Impédan
e d'entrée haute et 
ir
uit equilibré par

rapport aux signaux d'entrée [21℄.

En premier lieu, on �xera le gain en utilisant l'équation suivante :

VOut = ((Sig+)− (Sig−))×

(

R4

R2
×

(

2 •Rf

Rg
+ 1

))

(4)

Selon [?℄, on peut utiliser un paquet des résistan
es R1 - R4 d'une même valeur

et �xer le gain en utilisant la résistan
e Rg. Dans 
e 
as, le gain de l'ampli�
ateur

d'instrumentation sera déterminé selon l'équation suivante.

AI =
R4

R2
×

(

2 •Rf

Rg
+ 1

)

(5)

C'est important que nous �xions le gain en tenant 
ompte de la valeur de tension

d'entrée et de sortie de 
haque dispositif. La �gure 57 illustre le s
héma général pour

le 
onditionnement des 
apteurs. On travaillera en prendre en 
ompte la �gure 57.

Nous 
onnaissons la valeur de la tension d'alimentation de 
ir
uit (5 V), et la valeur

de

R2

R1+R2
(Table 4) et la plage pour le rapport

Rx
Rx+R3

, selon les 
onsidérations que

nous avons montré dans la table 2.

Nous reprenons l'équation 3, et on va rempla
er les valeurs 
omme se montre ensuite.

VDB = VCC •

(

R2

R1 +R2
moyenne−

Rx

Rx+R3
max/min

)

(6)

De 
ette manière, nous avons deux entrées possibles pour l'ampli�
ateur :

� Le 
as 1 :

VDBmax = 5V • (0.9790− 0.17) = 4.045 (7)

� Le 
as 2 :

VDBmin = 5V • (0.9790− 0.909) = 0.35 (8)

Nous obtiendrons les valeurs montrées dans les equations (7) et (8). Alors, la sortie

peut 
hanger entre 4.045 et 0.35. Pour régler la plage, on va pro�ter du gain de

l'ampli�
ateur de mesure. Pour 
ette raison, on va 
onsidérer un gain de 1.25 à peu

près. De 
ette manière, on travaillera ave
 une plage de valeurs par rapport à la sortie

entre 0.43 et 5. Cette plage fa
ilitera le travail ave
 un 
onvertisseur analogique-

numérique (CAN).
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(a) Disposition interne de 
haque blo
.

(b) S
héma resumée.

Figure 57 � S
héma général pour le 
onditionnement des 
apteurs

4.2.4 Calibrage des 
apteurs

Les fournisseurs ont fait des essais de 
alibration en utilisant une barre de 4 mm 
ouvert

d'un 
aout
hou
 de 2 mm d'épaisseur.

De notre 
�té, on a implémenté le système montre dans la �gure 58, on a pla
é des rondelles

de la même taille que la surfa
e a
tive des 
apteurs. L'idée est d'utiliser di�érents poids sur
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la surfa
e de 
onta
t et d'a
tivation de nos 
apteurs, dans notre 
as (37.21mm2
).

Pour faire le 
alibrage des 
apteurs, on a utilisé le s
héma qui montre la �gure 58.

L'obje
tif de 
hanger de poids et d'établir la 
ourbe de 
omportement de 
haque 
apteur

(a) Capteur

FSR

(b) Capteur

ave
 une petite

rondelle

(
) Capteur

ave
 rondelle

(d) Poids

Figure 58 � Calibration des 
apteurs FSR


omment la �gure 52 a montré.

Après des di�érents essais, on a trouvé que la 
ourbe 
ara
téristique de la for
e en fon
tion

de la résistan
e de 
haque 
apteur 
orrespond à l'équation suivante :

Force = a ∗ resistcapb (9)

Où,

a et b sont 
onstantes obtenus à travers des expérien
es développées et resist
ap est la

résistan
e qui donne 
haque 
apteur. Les valeurs sont présentées i
i :

Force = 175544.430379465 ∗ resistcap−1.0764947921
(10)

4.2.5 Mise en pla
e des 
apteurs de pression sur le for
eps

La position des 
apteurs sera dé�nie en prenant en 
ompte le bon fon
tionnement et la

bonne mesure de la for
e et la déformation apppliquée sur la tête foetale. En premier lieu,

les 
apteurs sont pla
és 
omme le montre la �gure 59.

Après, l'idée est de faire des essais, a�n d'assurer la répétitivité des expérien
es et la pré
ision

des mesures, pour 
ette raison, on 
hangera la position des 
apteurs en 
her
hant le meilleur

empla
ement.

On a fait des expérien
es en utilisant le for
eps Pajot que montre la �gure 59. On a déterminé

qu'on peut pro�ter du 
omportement de 
apteurs et de la symétrie des for
es exer
ées sur

la tête foetale, 
omment la �gure 60 montre.

Du 
oup, on a bas
ulé tous les 
apteurs dans un seul 
�té, 
'est-à-dire, seulement une 
uillère

aura les 
apteurs et en plus, dans 
e 
as, on a utilisé le for
eps modèle Levret. La �gure 61
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Figure 59 � Disposition initiale des 
apteurs sur le for
eps

Figure 60 � For
es mesurées pour les 
apteurs

illustre le 
hangement.

Le pla
ement des 
apteurs sur un �lm plastique fa
ilite la mise en pla
e de 
apteurs sur

Figure 61 � Disposition de 
apteurs sur une 
uillère de for
eps

n'importe quel modèle de for
eps.
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4.3 Capteur d'é
artement

Nous avons developpé une piè
e a�n de �xer les 
uillères du for
eps et aussi, 
ette piè
e

permettra de mesurer l'ouverture du for
eps. Dans la �gure 62, vous pouvez voir le design.

(a) Design de la piè
e

en utilisant le logi
iel

3DSMax.

(b) Impression 3D.

Figure 62 � Piè
e pour �xer les 
uillères du for
eps

De même, on utilisera un potentiomètre qui nous permettra de 
onnaître l'ouverture du

for
eps, en utilisant la résistan
e. Le potentiomètre a une résistan
e variable entre 0 Wet 10k

W, 
ependant la variation sera entre 0 Wet 1.5 k W.

4.3.1 Mise en pla
e de 
apteur

Cette piè
e sera �xée au milieu, dans la partie ronde, 
omme le montre la �gure 63 
i-dessous.

D'autre 
�té, on va mesurer l'é
artement des 
uillères du for
eps par rapport à la résistan
e

donnée par le potentiomètre.

La �gure 64, montre le 
ir
uit utilisé a�n de ré
uperer la valeur de la résistan
e.

4.4 Ré
upération et traitement des données :

4.4.1 Cara
téristiques de la Carte Arduino

Après l'étape de 
onditionnement, il faut que nous ré
upérions les données a�n d'analyser

l'information que donne 
haque 
apteur. À 
ette e�et, nous utiliserons une 
arte Arduino

UNO. Cette 
arte a les 
ara
téristiques suivantes (Figure 65) :

� Alimentation : port USB ou 
onnexion externe.

� Tension de fon
tionnement : 5V
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(a) Em-

pla
ement

séle
tionné pour

la piè
e.

(b) Piè
e pla
ée

sur le for
eps.

Figure 63 � Disposition de la piè
e sur le for
eps

� 6 entrées analogiques 10 bits

� 16 entrées/sorties numériques

4.4.2 Connexion des Capteurs de pression sur la 
arte Arduino

Pour notre appli
ation, on bran
hera 
haque sortie de nos ampli�
ateurs de mesure aux

entrées analogiques que fournit Arduino Uno [22℄,
omme la �gure 66 l'illustre.

Dans la �gure 66, PW est l'abréviation pour Pont de Wheatstone et AI 
orrespond à Am-

pli�
ateur d'Instrumentation.

4.4.3 Connexion de Capteur d'é
artement sur la 
arte Arduino

Dans le 
as de potentiomètre, on a utilisée aussi la 
on�guration de Pont Wheatstone, que

nous avons exprimée dans la se
tion 4.3.1. Cependant, on a ajouté une petite résistan
e,

a�n d'assurer que la mesure de la tension Vdb soit toujours supérieure à zero, 
omment la

�gure 64 montre.

On utilisera l'entrée analogique numéro 5, a�n de ré
uperer la valeur de la résistan
e, 
omme

l'illustre la �gure 67.
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Figure 64 � S
héma utilisée pour ré
uperer la valeur de la résistan
e

Figure 65 � Disposition des bro
hes dans la Carte Arduino Uno. Adaptée de [22℄
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Figure 66 � S
héma général de 
onnexion pour le 
onditionnement des 
apteurs et ré
upé-

ration des données
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Figure 67 � S
héma pour ré
uperer la valeur de la résistan
e de potentiomètre
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4.4.4 Codage sur Arduino

De même, 
'est né
essaire de 
ommander la 
arte Arduino UNO en utilisant l'ordinateur.

Il y a un logi
iel qui s'appelle Arduino (disponible depuis sa page o�
ielle : https://www.

arduino.

/en/Main/Software) qui permet de faire la programmation de la 
arte en uti-

lisant des 
ommandes fa
iles. Aussi, la stru
ture des 
odes dans le logi
iel Arduino suivi le

s
héma suivant :

//Définition des variables

void setup()

{

// ...

}

void loop()

{

// ... }

Les 
odes développés sur Arduino, se montrent dans la se
tion Annexes.

https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Main/Software
https://www.arduino.cc/en/Main/Software
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4.5 Interfa
e Graphique

Pour faire des analyses des données de manière plus fa
ile, on a développé une interfa
e

graphique qui permet d'observer les 
hangements de 
apteurs de pression.

Dans 
e 
as, on a utilisé le logi
iel Pro
essing (disponible depuis sa page o�
ielle : https://

pro
essing.org/ que fa
ilite le développement de plusieurs appli
ations en 2D et 3D. Ce

logi
iel est disponible sur les systèmes d'exploitation Windows, Ma
 et Linux.

Dans la �gure 68, on peut regarder l'interfa
e 
rée en utilisant Pro
essing.

Figure 68 � Interfa
e pour la visualisation des 
apteurs de pression

Nous pouvons véri�er le fon
tionnement de 
haque 
apteur et on a la possibilité de sauvegar-

der les donnés dans un �
hier de texte. Quand on appuie sur 
ette option on 
rée un �
hier

qui s'appelle sensores.txt. Ave
 le �
hier de texte, nous pouvons gérer les données selon nos

besoins. Par exemple, on a dé
idé de faire l'exportation des données au logi
iel Mi
rosoft

O�
e Ex
el.

https://processing.org/
https://processing.org/
https://processing.org/
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5 Con
lusions et travaux futurs

� En utilisant le logi
iel 3DS Max 2015 d'Autodesk, on peut travailler de manière fa-


ile quand on utilise des maillages polygonaux. Cependant, l'outil de 
onversion de

maillages polygonaux a�n d'obtenir NURBS génère beau
oup des erreurs 
omment

la perte des 
ara
téristiques physiques du maillage.

� Le NURBS que génère 3DS Max n'est pas exploitable. Il génère un maillage en mo-

saïque à partir des polygones originaux. Il faut utiliser d'autre outil si nous avons

besoin de travailler ave
 Nurbs.

� La 
onversion du maillage en utilisant Rhino o�re beau
oup des options a�n d'obtenir

une surfa
e. Cependant, il y a le risque d'obtenir des surfa
es qui ont les normales in-

versées. Ce problème provoque des sou
is dans les traitements suivants, par exemple,

dans la 
réation de tétraèdres. C'est toujours né
essaire que nous 
hangions les orien-

tations des normales.

� C'est possible d'ajouter des 
apteurs de pression additionnels, a�n de mesurer de

manière 
omplète les for
es exer
es par le for
eps dans la tête foetale. Cependant,

il faut 
hoisir une 
arte Arduino ave
 plusieurs entrées analogiques ou d'autre 
arte

éle
tronique plus puissante.

� Les for
es qui son mesures en utilisant les 
apteurs de pression ont été 
onsidérées

symétriques dans 
haque 
uillère du for
eps, a�n de fa
iliter les expérien
es et de

pouvoir mesurer dans di�érents points.

� Quand la for
e de 
haque 
apteur et l'é
artement ont été mesurée, on peut faire la

supposition que la somme de 
ha
un des for
es sera la for
e totale que la personne a

exer
ée en utilisant le for
eps sur la tête foetale.

� C'est intéressant aussi d'obtenir les for
es qui donnent les 
apteurs et faire une 
om-

paraison ave
 les for
es que le simulateur Birthsim obtienne. A�n de réaliser 
ette

pro
édure, il faut que on tienne en 
ompte les déformations produites sur la tête foe-

tale. Pour 
ette raison, 
'est né
essaire si nous pouvons parler d'un travail (for
e *

distan
e).
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6 Annexes

6.1 Annexe A. Code Arduino

/*Defini
ion de variables*/

int sensor1,sensor2,sensor3,sensor4,sensor5,sensor6;

//usar estas dos variables si se 
one
tan los sensores 7 y 8

int sensor7,sensor8;

float Tension_sensor1,Tension_sensor2,Tension_sensor3,Tension_sensor4;

float Tension_sensor5,Tension_sensor6;

//usar estas dos variables si se 
one
tan los sensores 7 y 8

float Tension_sensor7,Tension_sensor8;

int alimenta
ion=5000,j; //5V Valor en mV

//Puente Wheatstone Sensor 1

int R11=987;/* 1k*/

int R21=45800;/* 47k*/

int R31=9850;/* 10k*/

//Puente Wheatstone Sensor 2

int R12=981;/* 1k*/

int R22=46300;/* 47k*/

int R32=9850;/* 10k*/

//Puente Wheatstone Sensor 3

int R13=992;/* 1k*/

int R23=46200;/* 47k*/

int R33=9880;/* 10k*/

//Puente Wheatstone Sensor 4

int R14=990;/* 1k*/

int R24=46300;/* 47k*/

int R34=9800;/* 10k*/

//Puente Wheatstone Sensor 5

int R15=987;/* 1k*/

int R25=46300;/* 47k*/

int R35=9860;/* 10k*/

//Puente Wheatstone Sensor 6

int R16=991;/* 1k*/

int R26=46300;/* 47k*/

int R36=9890;/* 10k*/

//Puente Wheatstone Sensor 7

int R17=990;/* 1k*/

int R27=46300;/* 47k*/
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int R37=9850;/* 10k*/

//Puente Wheatstone Sensor 8

int R18=986;/* 1k*/

int R28=46200;/* 47k*/

int R38=9870;/* 10k*/

//Puente Wheatstone Poten
iometro

int R17=995;/* 1k*/

int R27=46400;/* 47k*/

int R37=997;/* 1k*/

float A,B,C,D,E,F,V;

//De
lara
ión Resisten
ia sensores

float Res_sensor1,Res_sensor2,Res_sensor3,Res_sensor4,Res_sensor5,Res_sensor6;

float Res_pot6;

//usar estas dos variables si se 
one
tan los sensores 7 y 8

float Res_sensor7,Res_sensor8;

float Fuerza_Tot,separa
ion[100℄, deforma
ion[100℄,Travail[100℄;

//De
lara
ión Fuerza sensores

double fuerza1,fuerza2,fuerza3,fuerza4,fuerza5,fuerza6,Res_pot6;

//usar estas dos variables si se 
one
tan los sensores 7 y 8

double fuerza7,fuerza8;

//Constantes en
ontradas por interpola
ion de la 
urva 
ara
teristi
a de los

//sensores

float 
ons=175544.430379465;

float 
ons1=-1.0764947921;

void setup(void)

{

Serial.begin(9600);

}

void loop (void)

{

sensor1 = analogRead(A0);

delay(2);

sensor2 = analogRead(A1);

delay(2);

sensor3 = analogRead(A2);

delay(2);

sensor4 = analogRead(A3);

delay(2);

sensor5 = analogRead(A4);
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delay(2);

sensor6 = analogRead(A5);

delay(2);

//usar estas dos variables si se 
one
tan los sensores 7 y 8

//sensor7 = analogRead(A6);

//delay(2);

//sensor8 = analogRead(A7);

//delay(2);

Tension_sensor1=map(sensor1,0,1023,0,alimenta
ion);

Tension_sensor2=map(sensor2,0,1023,0,alimenta
ion);

Tension_sensor3=map(sensor3,0,1023,0,alimenta
ion);

Tension_sensor4=map(sensor4,0,1023,0,alimenta
ion);

Tension_sensor5=map(sensor5,0,1023,0,alimenta
ion);

Tension_sensor6=map(sensor6,0,1023,0,alimenta
ion);

//usar estas dos variables si se 
one
tan los sensores 7 y 8

//Tension_sensor7=map(sensor6,0,1023,0,alimenta
ion);

//Tension_sensor8=map(sensor6,0,1023,0,alimenta
ion);

A= (Tension_sensor1/alimenta
ion)-(R21/(R11+R21));

B= (Tension_sensor2/alimenta
ion)- (R22/(R12+R22));

C= (Tension_sensor3/alimenta
ion)- (R23/(R13+R23));

D= (Tension_sensor4/alimenta
ion)- (R24/(R14+R24));

E= (Tension_sensor5/alimenta
ion)- (R25/(R15+R25));

F= (Tension_sensor6/alimenta
ion)- (R26/(R16+R26));

//usar estas dos variables si se 
one
tan los sensores 7 y 8

//G= (Tension_sensor7/alimenta
ion)- (R27/(R17+R28));

//H= (Tension_sensor8/alimenta
ion)- (R28/(R18+R28));

V= (Tension_sensor6/alimenta
ion);

Res_sensor1=-(R31*A)/(1+A);

Res_sensor2=-(R32*B)/(1+B);

Res_sensor3=-(R33*C)/(1+C);

Res_sensor4=-(R34*D)/(1+D);

Res_sensor5=-(R35*E)/(1+E);

Res_sensor6=-(R36*F)/(1+F);

//usar estas dos variables si se 
one
tan los sensores 7 y 8

//Res_sensor7=-(R37*G)/(1+G);

//Res_sensor8=-(R38*H)/(1+H);

Res_pot6=(R37*V)/(1-V);

fuerza1=
ons*pow(Res_sensor1,
ons1);

fuerza2=
ons*pow(Res_sensor2,
ons1);
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fuerza3=
ons*pow(Res_sensor3,
ons1);

fuerza4=
ons*pow(Res_sensor4,
ons1);

fuerza5=
ons*pow(Res_sensor5,
ons1);

fuerza6=
ons*pow(Res_sensor6,
ons1);

//usar estas dos variables si se 
one
tan los sensores 7 y 8

fuerza7=
ons*pow(Res_sensor7,
ons1);

fuerza8=
ons*pow(Res_sensor8,
ons1);

// Imprimir valores de las fuerzas medidas

Serial.print(fuerza1);

Serial.print(" ");

Serial.print(fuerza2);

Serial.print(" ");

Serial.print(fuerza3);

Serial.print(" ");

Serial.print(fuerza4);

Serial.print(" ");

Serial.print(fuerza5);

Serial.print(" ");

Serial.print(fuerza6);

Serial.println(" ");

//usar estas dos variables si se 
one
tan los sensores 7 y 8

//Serial.print(fuerza7);

//Serial.println(" ");

//Serial.print(fuerza8);

//Serial.println(" ");

delay(300);

}
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6.2 Annexe B. Code Pro
essing

//de
lara
ión librerias

import pro
essing.serial.*;

import 
ontrolP5.*;

//De
lara
ion de variables

PrintWriter datos;

Serial PuertoArduino; // Puerto serial

String inString; // Input desde Puerto serial

int lf = 10; // ASCII salto de linea

float x1 = 0;

float x2;

float y1;

float y2 = height / 2;

int xPos = 1;

PImage foto, foto1;

String[℄ lista;

float[℄ listaY = new float[10℄;

// Agregar 
olor si se grafi
an más de 6 valores

int[℄ 
olores = { #0000FF, #CC00AA, #00FFAA, #74DF00, #FFFF00, #FF0000, #F7FE2E};

ControlP5 
p5;

void setup()

{

//Tamaño de la Ventana

size(800, 600);


p5 = new ControlP5(this);


p5.addButton("Sauvegarder donnes")

.setValue(0)

.setPosition(700,200)

.setSize(100,15)

.setColorBa
kground(
olor(0, 0, 0))

;

// Imprime todos los puertos disponibles

printArray(Serial.list());

//Para este 
aso, Serial.list()[1℄, SE DEBE CAMBIAR ESTE VALOR

// POR EL PUERTO CORRESPONDIENTE

PuertoArduino = new Serial(this, Serial.list()[1℄, 9600);

PuertoArduino.bufferUntil(lf);

//
rea un ar
hivo txt
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datos = 
reateWriter("sensores.txt");

ba
kground(0);// 
olor de fondo

textSize(30);// Tamaño del texto

//Cargar logos de las universidades

foto = loadImage("liris2.png");

foto1 = loadImage("unal.jpg");

}

void draw()

{

if (inString != null)

{

// Remueve los espa
ios en blan
o:

inString = trim(inString);

//Espa
io para mostrar los datos

fill(255);

stroke(0);

re
t(0, 0, 800, 50);

fill(255);

stroke(0);

re
t(0, 50, 479, 100);

//Le
tura de 
ada sensor

fill(0, 0, 255);

text("S1", 20, 90);

fill(204, 0, 170);

text("S2", 100, 90);

fill(0, 255, 170);

text("S3", 180, 90);

fill(116, 223, 0);

text("S4", 260, 90);

fill(255, 255, 0);

text("S5", 330, 90);

fill(255, 0, 0);

text("S6", 410, 90);

fill(0, 0, 0);

text(inString, 10, 130);

fill(0, 0, 255);

text("Projet SAGA:", 20, 40);

fill(0, 0, 0);

text(" Capteurs de pression sur le for
eps", 200, 40);

image(foto, 480, 51, 160, 99);
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image(foto1, 640, 51, 160, 99);

// Separa los valores re
ibidos usando espa
io

lista = split(inString, ' ');

// Mostrar lista

printArray(lista);

// Re
orre la lista de valores

for (int i=0; i < lista.length; i++)

{

// Convierte el valor en su representa
ion numeri
a ( Float )

float inByte = float(lista[i℄);

datos.print(inByte+","); // 
opia el dato en sensores.txt

// Re
upera el valor guardado de la itera
ion anterior para usarlo

//
omo 
oordenada

y1 = listaY[i℄;

// mapeo segun tamaño de la pantalla

inByte = map(inByte, 0, 40, 0, height);

// dibujar la linea

stroke(
olores[i℄);

y2 = height - inByte;

line(xPos - 5, y1, xPos, y2);

// Guarda la 
oordenada y a
tual

listaY[i℄ = y2;

// 
uando se a
abe la linea, se vuelve al 
omienzo de la pantalla

if (xPos >= width)

{

xPos = 0;

ba
kground(0);

}

else

{

// in
remento en la posi
ión horizontal

xPos+=1;

}

}

datos.println(" "); //

// Sin
ronizar el retardo 
on el programa que envia

//los valores al puerto serial

delay(300);

}

}
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void serialEvent(Serial p)

{

inString = p.readString();

}

publi
 void 
ontrolEvent(ControlEvent theEvent)

{//presionar botón para guardar y salir

println(theEvent.getController().getName());

datos.flush();

datos.
lose();

exit();

}

void keyPressed()

{//Presionar 
ualquier te
la para guardar y salir

datos.flush();

datos.
lose();

exit();

}
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6.3 Annexes C. Carte de Prototypage

Vous pouvez trouver dans la �gure 69, la disposition des 
apteurs dans la 
arte de prototy-

page. En sa
hant que S1 
orrespond au 
apteur 1, et
. I
i, il y a huit 
apteurs pour donner

la possibilité d'obtenir plusieurs mesures. Il faut, alors, qu'on utilise une 
arte Arduino ave


plusieurs entrées analogiques ou d'autre 
arte éle
tronique a�n de ré
upérer les valeurs de


haque 
apteur. Si vous voulez faire de nouveau les expérien
es, pour vous-même, il faut que

Figure 69 � Disposition de 
omposants éle
troniques pour 
haque 
apteur sur la 
arte de

prototypage

vous teniez en 
ompte les 
onseils suivants :

� Suivre le s
héma ele
tronique de la �gure 70. De même, dans la �gure 71, vous pouvez

trouver les 
onnexions faites pour 
haque 
apteur.

� Les 
onnexions doivent être véri�es, a�n de voir que le 
ir
uit fon
tionne de manière


orre
te.

� Il y a deux sour
es d'alimentation :

� 5V (Sortie Arduino) : Cette tension est utilisée pour tous les 
ir
uits Pont de

Wheatstone.

� 6.3 V (Sour
e d'alimentation externe) : Cette tension est utilisée pour les 
ir
uits

de 
onditionnement (
hip MCP6004)
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Pour 
ette raison, 
'est important de ne pas mélanger l'alimentation, par
e que la


on
eption du 
ir
uit 
hangera et les valeurs de tension de sortie pour 
haque 
apteur

ne seront pas appropriées.

� C'est important que vous n'oubliez pas bran
her les masses. Les deux masses doivent

être bran
hées. A�n d'éviter des pertes dans le 
ir
uit que peuvent perturber le fon
-

tionnement des 
apteurs.

� Vous devez respe
ter les valeurs des résistan
es a�n de garantir le bon fon
tionnement

du 
ir
uit.

Figure 70 � S
héma ele
tronique du 
ir
uit implementé

6.4 Annexes D. Couplage Dspa
e Birthsim

Si vous êtes intéressée par faire la 
onnexion de 
e projet au Simulateur Birthsim. Vous

pouvez pro�ter et vous pouvez faire des 
onnexions dire
tement en utilisant les 
âbles VNC

qui se trouvent déjà bran
hés à Dspa
e. Il faut que vous suiviez les pas suivants :

� Vous devez bran
her les huit 
âbles aux sorties de 
haque 
apteur en suivant le 
ode

de 
ouleur qui se montre ensuite : Ou vous pouvez suivre le s
héma qui se montre

dans la �gure 72.
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S1 Jaune

S2 Noir

S3 Café

S4 Violette

S5 Orange

S6 Bleu

S7 Blan


S8 Rouge

Table 5

� Vous devez bran
her la masse des 
âbles VNC à la masse de votre 
arte de prototypage

Arduino.
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Figure 71 � Connexion de 
omposants éle
troniques pour un 
apteur sur la 
arte de proto-

typage
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Figure 72 � Connexion de 
âbles depuis huit 
âbles de type VNC, pour 
haque 
apteur sur

la 
arte de prototypage
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