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Traitement d’images sous FIJI 

 

1) Présentation du logiciel FIJI 
Le logiciel FIJI permet d’utiliser une interface de traitement d’images et de développer des 
plugins adaptés à chaque problématique. 
- Facile à installer: https://fiji.sc/ 
- Multiplateformes: Microsoft, MacOS, Linux 
- Licence libre (GNU General Public License) 
- Publication associée: Schindelin, J., Arganda-Carreras, I., Frise, E., Kaynig, V., Longair, M., 
Pietzsch, T., … Cardona, A. (2012). Fiji: an open-source platform for biological-image 
analysis. Nature Methods, 9(7), 676–682. doi:10.1038/nmeth.2019 

2) Avant de commencer 
Les images sont des données. N'écrasez JAMAIS un fichier image original. Si vous apportez 
des modifications à l'image, enregistrez-la dans un nouveau fichier. 
- Gardez la trace des manipulations que vous avez effectuées sur chaque image, par exemple 
dans un simple fichier texte que vous placez dans le même dossier que l'image. 
- Étant donné que le traitement d'image modifie l'apparence d'une image, vous devez examiner 
attentivement les implications éthiques de ce que vous faites. Comment les changements que 
vous effectuez affectent-ils l'interprétation et la présentation de vos données ? 
- À l'exception des simples ajustements linéaires de l'histogramme (intensité) appliqués de 
manière éthique, de la réduction de la profondeur de bits et du recadrage, toutes les procédures 
de traitement d'image doivent être divulguées dans la section Méthodes et/ou la légende d’une 
figure. 
 
Un compte-rendu est demandé pour ce TP en pdf dans lequel vous devez mettre vos résultats 
(images, histogrammes, tableau de comparaison des mesures…) en expliquant les méthodes 
employées.  
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3) Prise en main du logiciel 
Lancer le logiciel FIJI. Le bandeau suivant doit apparaître : 
 

 
 
Ouvrir l’image boats.gif (action open du menu file). 
Interpréter les informations relatives à cette image affichées en haut de l’image en vous aidant 
du complément donné par les commandes : 
Image > Type 
Image > Show info. 
Image > Properties 
 
NB : Par convention nous noterons le recours à des commandes FIJI en spécifiant le menu et le 
cheminement selon par exemple : Image > show info. 
 
Recalculer la taille de l’image en KiloOctets (K) sachant que 1octet = 8 bits et 1Ko=1024 octets. 
Mettez ce calcul dans le compte-rendu ainsi que les informations principales de l’image. 
 
Refaire de même avec l’image leaf.jpg (image couleur). A quoi correspondent les différents 
canaux ? 
 
Note sur l’aide: Le menu ‘help’ propose d’accéder à l’aide. L’aide est aussi accessible via le 
champ textuel en bas à droite du bandeau où l’on peut saisir des mots clés. Enfin, une 
documentation détaillée est disponible à l’adresse : https://imagej.net/ 
 
4. Manipulations d’images élémentaires 
 
Avant toute manipulation, il est nécessaire de faire une copie de l’image de départ avec la 
commande Image > Duplicate. Ceci permet de garder l’image de départ intacte, même si la 
commande Edit > Undo permet d’annuler la commande (mais une seule fois). On conseille 
d’ailleurs de noter les opérations successives réalisées car on peut vite s’y perdre… 
  

A) Agrandissement et réduction d’image 
 

Ces fonctionnalités sont accessibles par Image > Zoom ou l’icone ou les touches + et -
Expérimenter sur boats.gif (Image > Open Samples).  
 
• Réduire l’image d’un facteur 4 (Image > Scale, option interpolation : None, en mettant 

xscale=0.25). Observer l’impact sur les paramètres de cette image. Quelle est la taille 
physique de cette image ? 
 

• Agrandir cette image d’un facteur 4. Comment se compare-t-elle à la première ? Pour 
objectiver cela, aidez-vous de la commande Process > Image Calculator qui permet de 
réaliser des opérations entre deux images (ici une soustraction) que vous devez sauver dans 
une image de 32 bits afin d’observer les valeurs positives et négatives (on peut renommer 
cette image sub_interpolation1_boat.gif).  

https://imagej.net/
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• Utiliser Process>Math>Abs sur l’image sub_interpolation1_boat.gif afin d’obtenir les 

différences en valeurs absolues sur cette image. Puis utiliser Analyze > Measure (Les 
informations souhaitées sont définies par Analyze > Set Measurements avant de lancer 
Analyse > Measure). Pouvez-vous calculer une erreur moyenne absolue entre les intensités 
deux images en utilisant ces outils ? Noter cette valeur dans le compte-rendu. Cette mesure 
se note aussi MAE (Mean Absolute Error). 

 
• Refaire les opérations précédentes en repartant de l’image réduite que vous interpolez avec 

Image>Scale en utilisant l’interpolation Bilinear (Filtre permettant d’agrandir l’image). Que 
pouvez-vous en dire ? Pouvez-vous comparer de manière objective ces 2 interpolations en 
utilisant l’erreur moyenne absolue entre les intensités ? Mettre ces mesures dans le compte-
rendu. 

 
• Remarque : Image > Adjust > size fait un peu le même travail en agissant sur les dimensions 

de l’image. On peut ainsi déformer les images. La commande Analyze > Tools > Scale Bar 
permet d’afficher un segment représentatif de la dimension (si la résolution est définie pour 
l’image). 

 
B) Filtrage et débruitage des images 

 
• Analyse de l’histogramme 

 
Ouvrir l’image region_cercle_cst.gif. En faire une copie et afficher son histogramme (Analyze 
>Histogram). A quoi correspond l’histogramme ? Soit h la fonction histogramme, à quoi 
correspond la valeur h(I) donné par FIJI ? A quoi correspondent la valeur moyenne, la valeur 
minimale et maximale ? Sauvegarder l’histogramme afin de le mettre dans votre rapport (File > 
Save As et choisir un format jpeg par exemple). 
 
• Ajout d’un plugin pour le calcul des mesures de qualité du débruitage 
 
Afin d’analyser la qualité du débruitage, installer le plugin java disponible via le site 
http://bigwww.epfl.ch/sage/soft/snr/  (télécharger SNR_.jar) 
 
Afin de réaliser cette opération, utilisez Plugins>New>Plugin cela ouvre une autre fenêtre. 
Effectuer ensuite File>Open et ouvrez le fichier téléchargé SNR_.jar. On vous propose ensuite 
de sauvegarder ce fichier, effectuer cette sauvegarde. Il faut ensuite relancer ImageJ et un item 
SNR apparaît dans la liste des plugins. 
 
• Ajout d’un bruit gaussien sur l’image 

 
Ouvrir de nouveau l’image region_cercle_cst.gif puis la dupliquer deux fois et additionner un 
bruit gaussien sur l’image region_cercle_cst.gif en utilisant Process>Noise>Addspecifiednoise 
avec deux valeurs différentes de Standard Deviation que vous choisissez. 
 
 
 
 

http://bigwww.epfl.ch/sage/soft/snr/
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• Analyse des images bruitées 
 

Ouvrir l’outil SNR présent dans plugin (Figure 1) et sélectionner l’image de référence comme 
étant region_cercle_cst.gif (c’est l’image non bruitée) et calculer les valeurs de SNR, PSNR, 
RMSE (Root Mean Square Error) et MAE (Mean Absolute Error) pour les deux images. Que 
pouvez-vous oberver ? Les équations sont données sur le site web du plugin. On choisira deux 
mesures le PSNR et le RMSE afin de simplifier.  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• Quantification de la qualité d’un filtre de débruitage 
 
Dupliquer l’image bruitée plusieurs fois et essayer différentes opérations de lissage ou de filtrage 
(Process>Smooth, ou Process>Filters>Gaussian Blur). Ajouter ces images au tableau de 
comparaison. Cela nous permet d’obtenir une analyse objective du débruitage (le PSNR doit 
augmenter et le RSME doit diminuer). Mettre les mesures trouvées dans le rapport en spécifiant 
bien les différents paramètres choisis pour le filtrage et sur quelle image bruitée vous travaillez 
(niveau de bruit utilisé). 
 
5. Fonctions plus avancées 
 
Nous travaillerons sur deux images, l’une pour laquelle tous les objets à extraire ont le même 
contraste relativement au fond (blobs.gif) et l’autre pour lequel les objets à extraire présentent 
différentes intensités (dot_blot.gif). L’objectif est d’extraire les différentes structures (opération 
appelée segmentation ou binarisation dans ce cas) afin de pouvoir les compter.  
 

A) Segmentation de l’image blobs.gif 

La segmentation consiste ici à transformer l’image en une image binaire (2 niveaux : noir, blanc). 
La façon la plus élémentaire de réaliser cela est de faire un seuillage : on définit un seuil 
d’intensité, les pixels dont la valeur est inférieure au seuil sont mis à 0, ceux dont la valeur est 
supérieure ou égale au seuil sont mis à 1.  
 
 

Figure 1 : Mesures du PSNR et du RMSE pour les images bruités 
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• Afficher l’histogramme de l’image. Déterminer une gamme de seuils possibles pour le 
seuillage en observant l’image et l’histogramme. Afin de bien observer l’image, vous pouvez 
également tracer un segment horizontal avec l’outil de sélection du bandeau FIJI et utiliser 
Analyse > Plot Profile. Indiquer dans le rapport, quelle plage de seuils vous auriez choisie 
sans outil automatique. 

• Ensuite, ajuster le seuil avec la commande Image > Adjust > Threshold. Vous pouvez 
spécifier plusieurs méthodes de seuillage automatiques par le sélecteur de gauche sous 
l’histogramme. Choisissez la méthode Otsu par exemple (Apply pour obtenir l’image 
binaire). Ce seuil est-il similaire au seuil que vous aviez déterminé ?  

 
• Une fois l’image binaire optimale obtenue, les structures dans l’image sont analysées par la 

commande Analyze > Analyze Particles (cocher l’option overlay, add manager). Le tableau 
Results vous donne une liste des régions avec des mesures d’aire, de moyenne d’intensité et 
d’autres mesures. Le ROI manager vous permet de cliquer sur une région et de la voir 
apparaître encerclée sur l’image binaire. (NB : Si vous souhaitez ajouter d’autres mesures 
dans le tableau Results, il faut sélectionner Analyse > Set Measurements et cliquer sur les 
mesures qui vous intéressent. Il faut le faire avant de lancer Analyse > Analyse Particles) 

 
• Il peut être intéressant d’analyser le nombre et la taille des particules présentes (Figure 2). 

Combien de structures sont présentes dans l’image et quelle est la surface de la plus grande 
d’entre elles ? Une analyse de la distribution de chaque mesure est possible en faisant un clic 
droit sur la souris lorsque l’on est dans le tableau Results. Il faut alors sélectionner 
« distribution ». Ensuite, si on sélectionne Area, cela nous donnera la distribution selon 
l’aire des éléments. Donner une image de cette distribution dans le compte-rendu et une image 
montrant quelle est la plus grande ROI dans cette image (un simple rectangle entourant cette 
région est suffisant). 
 

 
Figure 2 : Analyse des particules dans FIJI 

 

 

 



Master 1 Recherche Biomédicale - UE RB14 - Informatique Médicale et Technologies de Communication, Faculté 
de Médecine Lyon Est, Enseignement : Traitement et analyse d'images 

6 
 

 

B) Segmentation de l’image dot_blot.jpg 

Vous réaliserez un travail similaire sur l’image dot_blot.jpg. Ajuster le seuil pour binariser avec 
la commande Image > Adjust > Threshold.  
 
Le seuil optimal n’est pas facile à trouver avec la méthode précédente : trop bas les structures ne 
sont pas très bien identifiées, trop haut, le noir peut se propager dans le fond. Des méthodes 
alternatives sont disponibles dans FIJI pour déterminer le seuil de manière locale.  
 
• Tester la commande Image > Adjust > Auto Local Threshold. Le paramètre « radius » 

peut être utilisé pour déterminer la taille de la fenêtre sur lequel s’applique le seuillage. 
Visualiser les résultats pour la méthode Otsu en changeant le paramètre radius. Comparer les 
résultats obtenus pour différents rayons (radius) en utilisant la méthode d’Otsu. On peut 
remarquer que même en changeant ce paramètre certains cercles ne sont pas très précis au 
niveau de la segmentation. 

 
Questions complémentaires :  
 
Il faudrait proposer des solutions pour améliorer cette segmentation  
 
• Essayer tout d’abord de rehausser l’image avec les méthodes vues en cours. Si on utilise 

Process>Enhance Contrast en sélectionnant egalize histogram, on peut remarquer que le 
fond n’est pas uniforme et ne permet pas d’obtenir un seuil facilement.  

 
• Pour résoudre cela, on peut tester la méthode de soustraction du fond Process > Substract 

Background. Cela transforme le fond en blanc. En utilisant l’opération Edit > Invert, on 
peut alors remettre le fond à 0.  

 
• Après cette opération de remise du fond à 0, on peut ré-utiliser Process>EnhanceContrast 

avec une égalisation d’histogrammes. Les cercles apparaissent nettement mais il y a de 
nombreux artefacts sur le fond. Observer le profil d’intensité le long d’une ligne horizontale 
en sélectionnant un segment puis Analyse > Plot Profile. L’obtention d’un seuil est possible 
pour obtenir toutes les particules mais pas nécessairement optimal pour la précision.  

 
• Retester le seuillage adaptatif avec différents rayons (auto local threshold). Les résultats ne 

sont pas optimaux en raison du bruit dans l’image. Effectuer alors un filtrage de l’image avec 
Process>Filters>Gaussian blur afin de lisser les images et ensuite retester le seuillage 
adaptatif (auto local threshold). Est-ce que ces pré-traitements permettent d’améliorer le 
résultat de binarisation ?  

 
• Dans le compte-rendu, vous pouvez mettre les différents résultats de binarisation obtenus 

avec ou sans pré-traitements pour le seuillage adapatif d’Otsu.  
 
 


